This documentation site is currently being updated to use version 6.0.0 as its base. It should be mostly the Configuration pages that have older images and text that menitions older versions. It is recognised that the images on the front page are a bit pathetic.

Compatibility